注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

浮游生物的博客

以扯蛋的态度面对操蛋的人生

 
 
 

日志

 
 

WampServer 中的PHP版本提升为5.3后,DEDECMS后台出现错误  

2011-08-30 10:10:46|  分类: PHP |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

WampServer 中的PHP版本提升为5.3后,DEDECMS后台登陆出现错误提示:

Deprecated: Function ereg_replace() is deprecated in d:\rootwww\dede\config.php on line 2

经查,原因是PHP5.3中已经废掉ereg_replace,换成preg_replace

解决方法:

    把:dede\config.php 中 define('DEDEADMIN', ereg_replace("[/\\]{1,}", '/', dirname(__FILE__) ) );

     换成:define('DEDEADMIN', preg_replace("/[\/\\\\]{1,}/", '/', dirname(__FILE__) ) );

OK!


  评论这张
 
阅读(1128)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018