注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

浮游生物的博客

以扯蛋的态度面对操蛋的人生

 
 
 

日志

 
 

WampServer 升级后PHPCMS 2008后台登陆错误的解决方法  

2011-09-01 14:55:47|  分类: PHP |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

WampServer升级为2.1,php版本为5.3,登陆PHPCMS出现页面错误,用火狐登陆后台出现错误提示:内容编码错误
无法显示您尝试查看的页面,因为它使用了无效或者不支持的压缩格式。

解决此错误方法是打开include目录下的config.inc.php,将

define('GZIP', 1); //是否Gzip压缩后输出

改为

define('GZIP', 0); //是否Gzip压缩后输出

 

然后成功显示后台,出现警告提示:

Deprecated: Function set_magic_quotes_runtime() is deprecated in XXX line 8

经检查的问题出在set_magic_quotes_runtime()函数上,提示内容 Function set_magic_quotes_runtime() is deprecated,导致这个提示的原因是在PHP5.3后此特性已经关闭,在PHP6中已经完全移除此特性,也就是这个函数已经不存在了。你可以注释或者删除掉出错的行,或者是在set_magic_quotes_runtime()前面加@符号。或者是:


 //@set_magic_quotes_runtime(0);

ini_set("magic_quotes_runtime",0);

 

就是用ini_set()办法替代原有的set_magic_quotes_runtime语法。



最简单的解决方法是打开PHP.INI文件,找到

error_reporting = E_ALL

改为

error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

基本意思就是忽略掉这些警告,OK!

  评论这张
 
阅读(1456)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018